summaryrefslogtreecommitdiffstats
path: root/examples/activeqt/simple/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/activeqt/simple/CMakeLists.txt')
-rw-r--r--examples/activeqt/simple/CMakeLists.txt23
1 files changed, 9 insertions, 14 deletions
diff --git a/examples/activeqt/simple/CMakeLists.txt b/examples/activeqt/simple/CMakeLists.txt
index 600defb..2d7cbc6 100644
--- a/examples/activeqt/simple/CMakeLists.txt
+++ b/examples/activeqt/simple/CMakeLists.txt
@@ -1,30 +1,25 @@
-# Generated from simple.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
-cmake_minimum_required(VERSION 3.14)
+cmake_minimum_required(VERSION 3.16)
project(simpleax LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/activeqt/simple")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-find_package(Qt6 COMPONENTS AxServer)
-
-add_qt_gui_executable(simpleax
+find_package(Qt6 REQUIRED COMPONENTS AxServer Core Gui Widgets)
+qt6_add_axserver_executable(simpleax
main.cpp
+ simple.def
+ simple.rc
)
+
target_link_libraries(simpleax PUBLIC
- Qt::AxServer
Qt::Core
Qt::Gui
Qt::Widgets