summaryrefslogtreecommitdiffstats
path: root/src/activeqt/control/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/activeqt/control/CMakeLists.txt')
-rw-r--r--src/activeqt/control/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/activeqt/control/CMakeLists.txt b/src/activeqt/control/CMakeLists.txt
new file mode 100644
index 0000000..c33411d
--- /dev/null
+++ b/src/activeqt/control/CMakeLists.txt
@@ -0,0 +1,47 @@
+# Generated from control.pro.
+
+#####################################################################
+## AxServer Module:
+#####################################################################
+
+qt_add_module(AxServer
+ STATIC
+ QMAKE_MODULE_CONFIG idcidl force_import_plugins
+ SOURCES
+ ../shared/qaxtypes.cpp ../shared/qaxtypes_p.h
+ qaxaggregated.cpp qaxaggregated.h
+ qaxbindable.cpp qaxbindable.h
+ qaxfactory.cpp qaxfactory.h
+ qaxmain.cpp
+ qaxserver.cpp
+ qaxserverbase.cpp
+ qaxserverdll.cpp
+ qaxservermain.cpp
+ qclassfactory_p.h
+ DEFINES
+ QAX_SERVER
+ PUBLIC_DEFINES
+ QAXSERVER
+ LIBRARIES
+ Qt::AxBasePrivate
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WidgetsPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+ shell32
+)
+
+#### Keys ignored in scope 1:.:.:control.pro:<TRUE>:
+# MODULE = "axserver"
+# MODULE_CONFIG = "idcidl" "force_import_plugins"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(AxServer CONDITION MINGW
+ DEFINES
+ QT_NEEDS_QMAIN
+)