summaryrefslogtreecommitdiffstats
path: root/tests/auto/conversion/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/conversion/CMakeLists.txt')
-rw-r--r--tests/auto/conversion/CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/tests/auto/conversion/CMakeLists.txt b/tests/auto/conversion/CMakeLists.txt
index 83ff23c..97e6c7f 100644
--- a/tests/auto/conversion/CMakeLists.txt
+++ b/tests/auto/conversion/CMakeLists.txt
@@ -1,16 +1,23 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from conversion.pro.
-
#####################################################################
## conversion Test:
#####################################################################
-qt_internal_add_test(conversion # special case
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(conversion LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(conversion
SOURCES
tst_conversion.cpp
+ INCLUDE_DIRECTORIES
+ ../../../src/activeqt/shared/
LIBRARIES
Qt::AxContainer
Qt::Gui
+ Qt::AxBasePrivate
)