summaryrefslogtreecommitdiffstats
path: root/tests/auto/dumpcpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/dumpcpp/CMakeLists.txt')
-rw-r--r--tests/auto/dumpcpp/CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/tests/auto/dumpcpp/CMakeLists.txt b/tests/auto/dumpcpp/CMakeLists.txt
index 85cdfe1..a5ff2dc 100644
--- a/tests/auto/dumpcpp/CMakeLists.txt
+++ b/tests/auto/dumpcpp/CMakeLists.txt
@@ -1,12 +1,16 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from dumpcpp.pro.
-
#####################################################################
## tst_dumpcpp Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_dumpcpp LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_dumpcpp
SOURCES
tst_dumpcpp.cpp
@@ -16,10 +20,5 @@ qt_internal_add_test(tst_dumpcpp
Qt::Widgets
)
-#### Keys ignored in scope 1:.:.:dumpcpp.pro:<TRUE>:
-# TYPELIBS = "$$(SystemRoot)\\system32\\ieframe.dll"
-
-qt6_target_typelibs(tst_dumpcpp LIBRARIES "ieframe.dll") # special case
-
-## Scopes:
-#####################################################################
+qt6_target_typelibs(tst_dumpcpp LIBRARIES "ieframe.dll")
+qt6_target_typelibs(tst_dumpcpp LIBRARIES "msxml6.dll")