aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 0 insertions, 27 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index f47f75c..0000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,27 +0,0 @@
-# Generated from qtandroidextras.pro.
-
-cmake_minimum_required(VERSION 3.15.0)
-
-include(.cmake.conf)
-project(QtAndroidExtras
- VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt AndroidExtras Libraries"
- HOMEPAGE_URL "https://qt.io/"
- LANGUAGES CXX C
-)
-
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui) # special case
-
-# special case begin
-if (NOT ANDROID)
- message(NOTICE "Skipping the build as the condition \"ANDROID\" is not met.")
- return()
-endif()
-# special case end
-
-if(NOT TARGET Qt::Gui)
- message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
- return()
-endif()
-
-qt_build_repo()