summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2c90733..e1dca564 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,9 +86,10 @@ if(AM_COVERAGE)
)
if(QT_BUILD_STANDALONE_TESTS)
- # this is currently hard-coded for Coin's standalone tests
+ # Coin splits the build into two separate directories, so we need to merge the coverage info
set(GCOV_EXTRA_FOLDER "../qtapplicationmanager_build")
set(LCOV_EXTRA_ARGS -d ${GCOV_EXTRA_FOLDER})
+ list(APPEND GCOV_EXCLUDE '/home/qt/work/qt/qtapplicationmanager_build/*')
endif()
set(COVERAGE_DEPENDS all)
if(QT_WILL_INSTALL)
@@ -100,7 +101,7 @@ if(AM_COVERAGE)
COMMAND sh -c 'which genhtml >/dev/null || { echo "The genhtml tool is not available." && exit 2 \; }'
COMMAND find . \\\( -name \"*.gcov-info\" -o -name \"*.gcda\" \\\) -print0 | xargs -0 rm -f
COMMAND lcov -keep-going -c -i -d . ${LCOV_EXTRA_ARGS} --rc branch_coverage=1 --rc geninfo_auto_base=1 -o "${CMAKE_CURRENT_BINARY_DIR}/base.gcov-info"
- COMMAND ctest --test-dir tests/auto --verbose
+ COMMAND ctest --test-dir tests/auto --verbose --repeat until-pass:3
COMMAND lcov -keep-going -c -d . ${LCOV_EXTRA_ARGS} --rc branch_coverage=1 --rc geninfo_auto_base=1 -o "${CMAKE_CURRENT_BINARY_DIR}/test.gcov-info"
COMMAND lcov -keep-going --rc branch_coverage=1 -o "${CMAKE_CURRENT_BINARY_DIR}/temp.gcov-info" `find . ${GCOV_EXTRA_FOLDER} -name \"*.gcov-info\" | xargs -n1 echo -a`
COMMAND lcov -keep-going --rc branch_coverage=1 -o "${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.gcov-info" -r temp.gcov-info ${GCOV_EXCLUDE}