summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Skoland <david.skoland@qt.io>2022-01-03 10:22:08 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-01-17 13:26:25 +0000
commitaa17dbd250e9802637ac8559ef6f24ca81b1cedd (patch)
treeffbb2f0d118117d0d9d17065a7d42aac4b66d8f6 /CMakeLists.txt
parent852b3d7648ec22b3f3c9d010c4aef1afd203c9ee (diff)
Include Qt6WasmMacros in WASM build
This fixes the issue where WASM could not even be configured with autotests enabled. Change-Id: I0890d52754de92fa84be170906fcb0478e90304e Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io> (cherry picked from commit 03c597ba15da375b0ce7aea195d1800ebd6a0189) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 751b82a546..e13ad11d09 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,6 +141,7 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
if(WASM)
# Needed when building for WebAssembly.
include(cmake/QtWasmHelpers.cmake)
+ include(src/corelib/Qt6WasmMacros.cmake)
qt_internal_setup_wasm_target_properties(Platform)
endif()