summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Skoland <david.skoland@qt.io>2022-01-03 10:22:08 +0100
committerDavid Skoland <david.skoland@qt.io>2022-01-03 17:34:18 +0100
commit03c597ba15da375b0ce7aea195d1800ebd6a0189 (patch)
tree52f2cb2ea1903ef848e38eeec380865d1d6e2f6b /CMakeLists.txt
parent63ffae3fa3a2627401878e7b948cb730118dc226 (diff)
Include Qt6WasmMacros in WASM build
This fixes the issue where WASM could not even be configured with autotests enabled. Change-Id: I0890d52754de92fa84be170906fcb0478e90304e Pick-to: 6.3 Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c272ab6f05..963ed295bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -123,6 +123,7 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
if(WASM)
# Needed when building for WebAssembly.
include(cmake/QtWasmHelpers.cmake)
+ include(src/corelib/Qt6WasmMacros.cmake)
qt_internal_setup_wasm_target_properties(Platform)
endif()