summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-04-12 15:04:14 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-04-25 09:02:59 +0000
commitaec0c269329c79dea6e2190855c764fbbbf063a3 (patch)
treed62f11a37296aca21f53ec9e69aaf3950e46e0c7 /CMakeLists.txt
parent0d780efd81beb102a83f9853ef786136c7de3fc0 (diff)
Introduce the qt_internal_project_setup macro
The macro sets the required CMake variables and policies and should be called right after the find_package(Qt6 COMPONENTS BuildInternals... call to make sure that the subsequent code adopt all the required policies. Task-number: QTBUG-112685 Change-Id: I9f93f728ee4d8ae7743db9fffafa26025c76dcf2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> (cherry picked from commit f3c10280f59d35fbf0862e6e353602e7aa8ef901) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c5141eb06..15142a6f1b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,6 +109,8 @@ else()
find_package(Qt6 REQUIRED COMPONENTS BuildInternals CMAKE_FIND_ROOT_PATH_BOTH)
endif()
+qt_internal_project_setup()
+
qt_build_repo_begin()
if(NOT QT_BUILD_STANDALONE_TESTS)