summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2022-01-05 12:38:22 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2022-01-07 14:31:38 +0100
commitb13ee89d20013ba4122e5539e9b5a0b65ee3ab6a (patch)
treed1d73fd063e09b402e812c6ba05ca305f59ea21e /CMakeLists.txt
parent0edbf7f97d816e057d02393eb5990aa6c8caf87a (diff)
Use REALPATH based check for symbolic links on Windows
Windows mount points are marked as symbolic links by CMake. So switch back to the REALPATH based check for Windows hosts. Amends dcc2704d17bda08e6dc7783559ccbfd864dd4339 Pick-to: 6.2 6.3 Task-number: QTBUG-99416 Change-Id: Ic996db1fac5c0b5edc18728535240e272dd435e0 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: David Schulz <david.schulz@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt42
1 files changed, 28 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 56fa1adb22..e13ad11d09 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,21 +14,35 @@ include(.cmake.conf)
# Bail out if any part of the build directory's path is symlinked.
function(qt_internal_check_if_path_has_symlinks path)
get_filename_component(dir "${path}" ABSOLUTE)
- while(TRUE)
- if(IS_SYMLINK "${dir}")
- message(FATAL_ERROR "The path \"${path}\" contains symlinks. \
-This is not supported. Possible solutions:
-- map directories using a transparent mechanism such as mount --bind
-- pass the real path of the build directory to CMake, e.g. using \
-cd $(realpath <path>) before invoking cmake <source_dir>.")
+ set(is_symlink FALSE)
+ if(CMAKE_HOST_WIN32)
+ # CMake marks Windows mount points as symbolic links, so use simplified REALPATH check
+ # on Windows platforms instead of IS_SYMLINK.
+ get_filename_component(dir_realpath "${dir}" REALPATH)
+ if(NOT dir STREQUAL dir_realpath)
+ set(is_symlink TRUE)
endif()
-
- set(prev_dir "${dir}")
- get_filename_component(dir "${dir}" DIRECTORY)
- if("${dir}" STREQUAL "${prev_dir}")
- return()
- endif()
- endwhile()
+ else()
+ while(TRUE)
+ if(IS_SYMLINK "${dir}")
+ set(is_symlink TRUE)
+ break()
+ endif()
+
+ set(prev_dir "${dir}")
+ get_filename_component(dir "${dir}" DIRECTORY)
+ if("${dir}" STREQUAL "${prev_dir}")
+ return()
+ endif()
+ endwhile()
+ endif()
+ if(is_symlink)
+ message(FATAL_ERROR "The path \"${path}\" contains symlinks. \
+ This is not supported. Possible solutions:
+ - map directories using a transparent mechanism such as mount --bind
+ - pass the real path of the build directory to CMake, e.g. using \
+ cd $(realpath <path>) before invoking cmake <source_dir>.")
+ endif()
endfunction()
qt_internal_check_if_path_has_symlinks("${CMAKE_BINARY_DIR}")