summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-11-18 10:27:47 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2021-11-30 20:16:13 +0100
commitd162ce3732bc125ad42c5c5e98050a8e09ab9054 (patch)
treebbd93892a79518526b230e8b57d2525bc0a67e25 /CMakeLists.txt
parent54536bb5aea2da08d97670810b3baf14f90ed4f5 (diff)
Add _make_aab target
Add target triggering AAB creation. Since the _make_aab target is not added to the ALL set, we may avoid dependency check for it and admit that the target is "always out of date". [ChangeLog][Android][Platform Specific Changes] Add the extra _make_aab targets for each executable target, that can be used to generate android app bundles. Also add aab metatarget to build all _make_aab targets that are created in the project. Pick-to: 6.2 Fixes: QTBUG-96710 Change-Id: I3b0c7fbb5a7dd493ca7a124c4e4b91fd857386bd Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f453505ee8..c272ab6f05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -117,7 +117,7 @@ if(NOT QT_BUILD_STANDALONE_TESTS)
# Needed when building qtbase for android.
if(ANDROID)
include(src/corelib/Qt6AndroidMacros.cmake)
- _qt_internal_create_global_apk_target()
+ _qt_internal_create_global_android_targets()
endif()
if(WASM)