summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAhmad Samir <a.samirh78@gmail.com>2023-07-21 01:04:40 +0300
committerAhmad Samir <a.samirh78@gmail.com>2023-09-08 19:17:36 +0300
commit09b852b1d8519db1b614a1a6438ff59a928f3b9f (patch)
tree4f1afedb79fbb7e9bbf3c2df491c41b3fbfec05e /examples/CMakeLists.txt
parent9016def4dc75e35509cc1a5f5168514b0d88af56 (diff)
examples/: compile with QT_NO_CONTEXTLESS_CONNECT
Examples are usually a good way to get to know a new codebase, do not teach developers who are new to Qt about the 3-arg connect() to begin with. Drive-by changes: - `this` can't be implicitly captured with [=] in a lambda, instead capture by reference - Update docs related to the sqlbrowser example; the overloaded signal it mentions has been removed in Qt6 - In the sqlbrowser example, rename addConnection() (no-arg) overload to openNewConnectionDialog, suggested in code review Change-Id: I30c9f35bda4ac2f460d767ab7f84422ae3ed09f7 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 0f6e6ba425..e7ed9033f4 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -3,6 +3,8 @@
qt_examples_build_begin(EXTERNAL_BUILD)
+add_compile_definitions(QT_NO_CONTEXTLESS_CONNECT)
+
add_subdirectory(corelib)
add_subdirectory(embedded)
if(TARGET Qt6::DBus)