summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-07 15:24:45 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 09:38:28 +0200
commit74cb331af3cfe723ae16cd1b00c9dd9291b4e7e9 (patch)
tree0f4ee41beba41f67a2ea0bb6c0134843a32c9ab6 /examples/CMakeLists.txt
parentd98a6d0463fd00e5463828b6a3e4e20db7d6d63e (diff)
CMake: Regenerate examples
Change-Id: I1c51b10af4e2b26f54740f257164c56a0e2a03ce Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt31
1 files changed, 8 insertions, 23 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index b473828415..a48879d447 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,54 +1,39 @@
-# special case begin
-qt_examples_build_begin()
-
-# special case end
-
# Generated from examples.pro.
+qt_examples_build_begin()
+
add_subdirectory(corelib)
add_subdirectory(embedded)
add_subdirectory(qpa)
-
if(TARGET Qt::DBus)
add_subdirectory(dbus)
endif()
-
if(TARGET Qt::Network)
add_subdirectory(network)
endif()
-
if(TARGET Qt::Test)
add_subdirectory(qtestlib)
endif()
-
if(TARGET Qt::Concurrent)
add_subdirectory(qtconcurrent)
endif()
-
if(TARGET Qt::Sql)
add_subdirectory(sql)
endif()
-
if(TARGET Qt::Widgets)
add_subdirectory(widgets)
endif()
-
if(TARGET Qt::Xml)
add_subdirectory(xml)
endif()
-
if(TARGET Qt::Gui)
add_subdirectory(gui)
-
- if(QT_FEATURE_opengl)
- add_subdirectory(opengl)
- endif()
-
- if(QT_FEATURE_vulkan)
- add_subdirectory(vulkan)
- endif()
+endif()
+if(QT_FEATURE_opengl AND TARGET Qt::Gui)
+ add_subdirectory(opengl)
+endif()
+if(QT_FEATURE_vulkan AND TARGET Qt::Gui)
+ add_subdirectory(vulkan)
endif()
-# special case begin
qt_examples_build_end()
-# special case end