summaryrefslogtreecommitdiffstats
path: root/examples/embedded/flightinfo/CMakeLists.txt
diff options
context:
space:
mode:
authorLucie Gérard <lucie.gerard@qt.io>2023-11-15 10:24:42 +0100
committerLucie Gérard <lucie.gerard@qt.io>2023-11-17 19:39:33 +0100
commit4c36bb854cb8deaa2841bf2aba7e71ea4b1a06dd (patch)
tree013e21393f897581de488fd02f03f6f800baa882 /examples/embedded/flightinfo/CMakeLists.txt
parent4bb230f65e9e27984479c07288a71797c8651b66 (diff)
Remove undocumented embedded examples
Task-number: QTBUG-119117 Change-Id: I7fd104742771e2ce6d4ad7afd66e2beca3b4f672 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/embedded/flightinfo/CMakeLists.txt')
-rw-r--r--examples/embedded/flightinfo/CMakeLists.txt50
1 files changed, 0 insertions, 50 deletions
diff --git a/examples/embedded/flightinfo/CMakeLists.txt b/examples/embedded/flightinfo/CMakeLists.txt
deleted file mode 100644
index 8e31aedd49..0000000000
--- a/examples/embedded/flightinfo/CMakeLists.txt
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(flightinfo LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/embedded/flightinfo")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Network Widgets)
-
-qt_standard_project_setup()
-
-qt_add_executable(flightinfo
- flightinfo.cpp
- form.ui
-)
-
-set_target_properties(flightinfo PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(flightinfo PRIVATE
- Qt6::Core
- Qt6::Gui
- Qt6::Network
- Qt6::Widgets
-)
-
-# Resources:
-set(flightinfo_resource_files
- "aircraft.png"
-)
-
-qt_add_resources(flightinfo "flightinfo"
- PREFIX
- "/"
- FILES
- ${flightinfo_resource_files}
-)
-
-install(TARGETS flightinfo
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)