summaryrefslogtreecommitdiffstats
path: root/examples/network/dnslookup/CMakeLists.txt
diff options
context:
space:
mode:
authorElias Hautala <elias.hautala@qt.io>2023-08-14 10:06:33 +0300
committerElias Hautala <elias.hautala@qt.io>2023-08-28 16:00:45 +0300
commit39a5ed4bdd348d3cd18a08d322b48d85e8d116e8 (patch)
tree8061c16db0f64df0f68600d49cbac7a32d212e4a /examples/network/dnslookup/CMakeLists.txt
parentc95555e9f7f703263ae3784efa0796d6804144c1 (diff)
Exclude some examples from Android build
Excludes dnslookup, waitconditions, semaphores, cbordump, savegame, convert, pingpong and complexpingpong examples from Android build because of missing Qui and Quick dependenies. Task-number: QTBUG-111933 Pick-to: 6.5 6.6 Change-Id: Ied01f62ee61a9220dcb44c13fda46f6a5e158293 Reviewed-by: Rami Potinkara <rami.potinkara@qt.io> Reviewed-by: Ville Voutilainen <ville.voutilainen@qt.io>
Diffstat (limited to 'examples/network/dnslookup/CMakeLists.txt')
-rw-r--r--examples/network/dnslookup/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/network/dnslookup/CMakeLists.txt b/examples/network/dnslookup/CMakeLists.txt
index e90cdaff2d..39f680f334 100644
--- a/examples/network/dnslookup/CMakeLists.txt
+++ b/examples/network/dnslookup/CMakeLists.txt
@@ -4,6 +4,10 @@
cmake_minimum_required(VERSION 3.16)
project(dnslookup LANGUAGES CXX)
+if (ANDROID)
+ message(FATAL_ERROR "This project cannot be built on Android.")
+endif()
+
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()