summaryrefslogtreecommitdiffstats
path: root/examples/network/dnslookup/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-11-21 12:03:41 +0100
committerKai Köhne <kai.koehne@qt.io>2022-11-30 14:48:50 +0100
commita5de12f0d7dfef64453b7b29c33dc760b3cacec4 (patch)
treec55549f8c325eb0a3a3eb09c5ac76a31d763fdbd /examples/network/dnslookup/CMakeLists.txt
parentd221ea609fdd9f5dc99f520391beddc057373278 (diff)
Examples: Use PRIVATE CMake linkage
We (almost) only build apps, for which PRIVATE linkage makes more sense. Change-Id: I09a509c3fb33a00cdfdede687b3f95d638f42091 Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/network/dnslookup/CMakeLists.txt')
-rw-r--r--examples/network/dnslookup/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/network/dnslookup/CMakeLists.txt b/examples/network/dnslookup/CMakeLists.txt
index c9668cc251..e90cdaff2d 100644
--- a/examples/network/dnslookup/CMakeLists.txt
+++ b/examples/network/dnslookup/CMakeLists.txt
@@ -18,7 +18,7 @@ qt_add_executable(dnslookup
dnslookup.cpp dnslookup.h
)
-target_link_libraries(dnslookup PUBLIC
+target_link_libraries(dnslookup PRIVATE
Qt6::Core
Qt6::Network
)