summaryrefslogtreecommitdiffstats
path: root/examples/network/downloadmanager/CMakeLists.txt
diff options
context:
space:
mode:
authorMårten Nordheim <marten.nordheim@qt.io>2023-02-27 15:16:34 +0100
committerMårten Nordheim <marten.nordheim@qt.io>2023-03-02 12:08:09 +0100
commiteb61d49ab3a4f4d9dae3ccfdaf416190fb168c27 (patch)
treefbb6b1a95eacbc3ce11d359ce99420b7e56e7acb /examples/network/downloadmanager/CMakeLists.txt
parent8dbceaa398d92c9c7492ffeb483f2bd6fab30c17 (diff)
Delete the Network Download (Manager)? examples
Their use of QtNetwork is already covered by the HTTP example. While showcasing that QNAM easily deals with multiple simultaneous requests, waiting until finished() is emitted to write anything is not exactly idiomatic. And managing your own queue to only have one request running at a time is a weird example for an asynchronous framework. In this regard, having an example for a complete download manager (with a GUI) would be interesting, but may ultimately be very time-consuming to make for limited gain. Task-number: QTBUG-110643 Pick-to: 6.5 Change-Id: I6b2c1546b85fa89ab7ce1ff5565b0293b5710b74 Reviewed-by: Timur Pocheptsov <timur.pocheptsov@qt.io> Reviewed-by: Ievgenii Meshcheriakov <ievgenii.meshcheriakov@qt.io> Reviewed-by: Konrad Kujawa <konrad.kujawa@qt.io>
Diffstat (limited to 'examples/network/downloadmanager/CMakeLists.txt')
-rw-r--r--examples/network/downloadmanager/CMakeLists.txt32
1 files changed, 0 insertions, 32 deletions
diff --git a/examples/network/downloadmanager/CMakeLists.txt b/examples/network/downloadmanager/CMakeLists.txt
deleted file mode 100644
index 7b108e31ea..0000000000
--- a/examples/network/downloadmanager/CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(downloadmanager LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/network/downloadmanager")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Network)
-
-qt_standard_project_setup()
-
-qt_add_executable(downloadmanager
- downloadmanager.cpp downloadmanager.h
- main.cpp
- textprogressbar.cpp textprogressbar.h
-)
-
-target_link_libraries(downloadmanager PRIVATE
- Qt6::Core
- Qt6::Network
-)
-
-install(TARGETS downloadmanager
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)