summaryrefslogtreecommitdiffstats
path: root/examples/opengl/legacy/hellogl/CMakeLists.txt
diff options
context:
space:
mode:
authorJohan Klokkhammer Helsing <johan.helsing@qt.io>2020-02-19 12:08:25 +0100
committerJohan Helsing <johan.helsing@qt.io>2020-02-21 09:01:08 +0000
commite3f2e7afbb22069ef3e2bed6017f8fa47909e9f1 (patch)
tree4b89e925ed3b5e74b49f56c18721ad33b610ba16 /examples/opengl/legacy/hellogl/CMakeLists.txt
parent8193f9e0ecc0a7592310e1c26310ba502c091374 (diff)
Remove legacy OpenGL examples
They all used QGL (which has been removed). Task-number: QTBUG-74408 Change-Id: Ied003625f14228b4951002a604fce91eaccec102 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@qt.io>
Diffstat (limited to 'examples/opengl/legacy/hellogl/CMakeLists.txt')
-rw-r--r--examples/opengl/legacy/hellogl/CMakeLists.txt40
1 files changed, 0 insertions, 40 deletions
diff --git a/examples/opengl/legacy/hellogl/CMakeLists.txt b/examples/opengl/legacy/hellogl/CMakeLists.txt
deleted file mode 100644
index 436f3190cc..0000000000
--- a/examples/opengl/legacy/hellogl/CMakeLists.txt
+++ /dev/null
@@ -1,40 +0,0 @@
-# Generated from hellogl.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(hellogl LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-set(INSTALL_EXAMPLEDIR "examples/opengl/legacy/hellogl")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS OpenGL)
-find_package(Qt6 COMPONENTS Widgets)
-
-add_qt_gui_executable(hellogl
- ../shared/qtlogo.cpp ../shared/qtlogo.h
- glwidget.cpp glwidget.h
- main.cpp
- window.cpp window.h
-)
-target_include_directories(hellogl PUBLIC
- ../shared
-)
-
-target_link_libraries(hellogl PUBLIC
- Qt::Core
- Qt::Gui
- Qt::OpenGL
- Qt::Widgets
-)
-
-install(TARGETS hellogl
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)