summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/map/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-10 18:31:58 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-10 18:35:07 +0100
commit3af9d49bb78ac56bff57d1c3867853730f97a8e1 (patch)
treec9d6c1d1fe90dba3c788fd06795cf05a6d4ed5bb /examples/qtconcurrent/map/CMakeLists.txt
parent71436d5499a9e0355f778f47ef465486a727049d (diff)
parentc431e2d33c2b13dee8b43a08c267c20ec1ae9654 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Diffstat (limited to 'examples/qtconcurrent/map/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/map/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/qtconcurrent/map/CMakeLists.txt b/examples/qtconcurrent/map/CMakeLists.txt
index 1707825b8f..e5a3ba1c66 100644
--- a/examples/qtconcurrent/map/CMakeLists.txt
+++ b/examples/qtconcurrent/map/CMakeLists.txt
@@ -9,17 +9,19 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/qtconcurrent/map")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Concurrent)
-find_package(Qt6 COMPONENTS Gui) # special case
add_executable(mapdemo
main.cpp
)
target_link_libraries(mapdemo PUBLIC
Qt::Concurrent
- Qt::Gui # special case
+ Qt::Core
+ Qt::Gui
)
install(TARGETS mapdemo
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"