summaryrefslogtreecommitdiffstats
path: root/examples/qtconcurrent/map/CMakeLists.txt
diff options
context:
space:
mode:
authorDennis Oberst <dennis.oberst@qt.io>2023-03-01 13:39:20 +0100
committerDennis Oberst <dennis.oberst@qt.io>2023-03-09 17:26:59 +0000
commitfbb470b40b2c86a55751bf3099cc0424f66c7274 (patch)
tree6de0373b8a005b160db93dfbfa54f3f1d08114bd /examples/qtconcurrent/map/CMakeLists.txt
parentb5e9d418959a9d427c14468886470791527e157f (diff)
Example: remove map example
This example only demonstrates the use of blockingMapped. Considering that the QtConcurrent::mapped~ functions are already included in the wordcount example, and have very similar APIs to the QtConcurrent::filter~ functions, which are included in the progressdialog example, this no longer serves a useful purpose. Task-number: QTBUG-111165 Pick-to: 6.5 6.5.0 Change-Id: Ibc526e1a9fb17070e376e45151e9c2bdbc69bd32 Reviewed-by: Ivan Solovev <ivan.solovev@qt.io>
Diffstat (limited to 'examples/qtconcurrent/map/CMakeLists.txt')
-rw-r--r--examples/qtconcurrent/map/CMakeLists.txt31
1 files changed, 0 insertions, 31 deletions
diff --git a/examples/qtconcurrent/map/CMakeLists.txt b/examples/qtconcurrent/map/CMakeLists.txt
deleted file mode 100644
index 9546e19773..0000000000
--- a/examples/qtconcurrent/map/CMakeLists.txt
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(mapdemo LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/qtconcurrent/map")
-
-find_package(Qt6 REQUIRED COMPONENTS Concurrent Core Gui)
-
-qt_standard_project_setup()
-
-qt_add_executable(mapdemo
- main.cpp
-)
-
-target_link_libraries(mapdemo PRIVATE
- Qt6::Concurrent
- Qt6::Core
- Qt6::Gui
-)
-
-install(TARGETS mapdemo
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)