summaryrefslogtreecommitdiffstats
path: root/examples/widgets/draganddrop/puzzle/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-26 13:48:57 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-28 00:09:58 +0200
commitcefb1c9ca9af73999247678907c496c1a143d00f (patch)
tree9d77b10e151289ffd862f6ef7f42dfc510be0611 /examples/widgets/draganddrop/puzzle/CMakeLists.txt
parent3a9526468c134b68b64b9a3bb6278d47c266e381 (diff)
Move drag and drop puzzle example to manual test
Pick-to: 6.5 6.6 Change-Id: I859cdb2cf74cd6272c29924c77dab26b4f4c0b6c Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/widgets/draganddrop/puzzle/CMakeLists.txt')
-rw-r--r--examples/widgets/draganddrop/puzzle/CMakeLists.txt51
1 files changed, 0 insertions, 51 deletions
diff --git a/examples/widgets/draganddrop/puzzle/CMakeLists.txt b/examples/widgets/draganddrop/puzzle/CMakeLists.txt
deleted file mode 100644
index 13c6717551..0000000000
--- a/examples/widgets/draganddrop/puzzle/CMakeLists.txt
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(puzzle LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/draganddrop_puzzle")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
-qt_standard_project_setup()
-
-qt_add_executable(draganddrop_puzzle
- main.cpp
- mainwindow.cpp mainwindow.h
- pieceslist.cpp pieceslist.h
- puzzlewidget.cpp puzzlewidget.h
-)
-
-set_target_properties(draganddrop_puzzle PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(draganddrop_puzzle PRIVATE
- Qt6::Core
- Qt6::Gui
- Qt6::Widgets
-)
-
-# Resources:
-set(puzzle_resource_files
- "example.jpg"
-)
-
-qt_add_resources(draganddrop_puzzle "puzzle"
- PREFIX
- "/images"
- FILES
- ${puzzle_resource_files}
-)
-
-install(TARGETS draganddrop_puzzle
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)