summaryrefslogtreecommitdiffstats
path: root/examples/widgets/gallery/CMakeLists.txt
diff options
context:
space:
mode:
authorSona Kurazyan <sona.kurazyan@qt.io>2020-04-28 10:44:54 +0200
committerSona Kurazyan <sona.kurazyan@qt.io>2020-04-29 22:48:38 +0200
commit9b51d5f5713c237c244c1bff4d0bd3d0437e1b95 (patch)
tree5970f713d6264edfd2961439f027b62da2077d73 /examples/widgets/gallery/CMakeLists.txt
parenta19d743b2cf61bbfebec8f56bfd09299c30f00a8 (diff)
CMake: Regenerate examples/widgets/ projects
Also add the missing examples/widgets/gallery project. Change-Id: Iec3d61881065cf93d90f9fd3da928ffcd4f0c0aa Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/gallery/CMakeLists.txt')
-rw-r--r--examples/widgets/gallery/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/examples/widgets/gallery/CMakeLists.txt b/examples/widgets/gallery/CMakeLists.txt
new file mode 100644
index 0000000000..67e2a6bede
--- /dev/null
+++ b/examples/widgets/gallery/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Generated from gallery.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(gallery LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples/widgets/gallery")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(gallery
+ main.cpp
+ widgetgallery.cpp widgetgallery.h
+)
+target_link_libraries(gallery PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
+install(TARGETS gallery
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)