summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/chip/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-20 13:41:37 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-26 15:25:39 +0000
commitaa50b377a7d904e35cf3a26e4c8a054108011ffd (patch)
treeff45946e5779357aa547f00a8b5b9d0119a2b8f2 /examples/widgets/graphicsview/chip/CMakeLists.txt
parent05ebd62f099b51b160a06e1257007bf437355fae (diff)
CMake: Add widgets examples
Change-Id: Ib6142b93df066e3658eb189b50ca74c455fe7e56 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/graphicsview/chip/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/chip/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/examples/widgets/graphicsview/chip/CMakeLists.txt b/examples/widgets/graphicsview/chip/CMakeLists.txt
new file mode 100644
index 0000000000..566a8aae02
--- /dev/null
+++ b/examples/widgets/graphicsview/chip/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Generated from chip.pro.
+
+#####################################################################
+## chip Binary:
+#####################################################################
+
+add_qt_executable(chip
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/chip"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/chip"
+ SOURCES
+ chip.cpp chip.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ view.cpp view.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(chip "images" FILES
+ fileprint.png
+ qt4logo.png
+ rotateleft.png
+ rotateright.png
+ zoomin.png
+ zoomout.png)
+
+
+## Scopes:
+#####################################################################
+
+extend_target(chip CONDITION TARGET Qt::PrintSupport
+ LIBRARIES
+ Qt::PrintSupport
+)
+
+extend_target(chip CONDITION TARGET Qt::OpenGL
+ LIBRARIES
+ Qt::OpenGL
+)
+
+#### Keys ignored in scope 4:.:chip.pro:build_all AND NOT build_pass:
+# CONFIG = "-build_all" "release"