summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/diagramscene/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-20 13:41:37 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-26 15:25:39 +0000
commitaa50b377a7d904e35cf3a26e4c8a054108011ffd (patch)
treeff45946e5779357aa547f00a8b5b9d0119a2b8f2 /examples/widgets/graphicsview/diagramscene/CMakeLists.txt
parent05ebd62f099b51b160a06e1257007bf437355fae (diff)
CMake: Add widgets examples
Change-Id: Ib6142b93df066e3658eb189b50ca74c455fe7e56 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/graphicsview/diagramscene/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/diagramscene/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/examples/widgets/graphicsview/diagramscene/CMakeLists.txt b/examples/widgets/graphicsview/diagramscene/CMakeLists.txt
new file mode 100644
index 0000000000..fb3ff6c712
--- /dev/null
+++ b/examples/widgets/graphicsview/diagramscene/CMakeLists.txt
@@ -0,0 +1,39 @@
+# Generated from diagramscene.pro.
+
+#####################################################################
+## diagramscene Binary:
+#####################################################################
+
+add_qt_executable(diagramscene
+ GUI
+ OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/diagramscene"
+ INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/diagramscene"
+ SOURCES
+ arrow.cpp arrow.h
+ diagramitem.cpp diagramitem.h
+ diagramscene.cpp diagramscene.h
+ diagramtextitem.cpp diagramtextitem.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+ LIBRARIES
+ Qt::Widgets
+)
+
+# Resources:
+add_qt_resource(diagramscene "diagramscene" FILES
+ images/background1.png
+ images/background2.png
+ images/background3.png
+ images/background4.png
+ images/bold.png
+ images/bringtofront.png
+ images/delete.png
+ images/floodfill.png
+ images/italic.png
+ images/linecolor.png
+ images/linepointer.png
+ images/pointer.png
+ images/sendtoback.png
+ images/textpointer.png
+ images/underline.png)
+