summaryrefslogtreecommitdiffstats
path: root/examples/widgets/graphicsview/padnavigator/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-06-04 17:08:47 +0200
committerKevin Funk <kevin.funk@kdab.com>2019-06-05 12:53:28 +0000
commit99539a289491a2a709c2a63cd91eac155a1699da (patch)
treed928d6c6e123c6588261bea9358354fe1e1a7400 /examples/widgets/graphicsview/padnavigator/CMakeLists.txt
parentace549587073d387823815b02ec85a28da408844 (diff)
Allow to build examples as standalone project
Create CMake config files which can be used from the very same CMake project. These CMake config files simply do not create any targets, controlled via the QT_NO_CREATE_TARGETS. This patch also allows to build qtbase.git:examples as a standalone project, against an already-built Qt. Ran this: ag -s "QT " examples -l -0 | xargs -0 -n 1 .../util/cmake/pro2cmake.py --is-example Task-number: QTBUG-74713 Change-Id: I44cce5a4048618b30f890c5b789592c227a8b47d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/graphicsview/padnavigator/CMakeLists.txt')
-rw-r--r--examples/widgets/graphicsview/padnavigator/CMakeLists.txt64
1 files changed, 28 insertions, 36 deletions
diff --git a/examples/widgets/graphicsview/padnavigator/CMakeLists.txt b/examples/widgets/graphicsview/padnavigator/CMakeLists.txt
index 9c4282391e..e995f2a16e 100644
--- a/examples/widgets/graphicsview/padnavigator/CMakeLists.txt
+++ b/examples/widgets/graphicsview/padnavigator/CMakeLists.txt
@@ -1,45 +1,37 @@
# Generated from padnavigator.pro.
-#####################################################################
-## padnavigator Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(padnavigator LANGUAGES CXX)
-add_qt_executable(padnavigator
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/padnavigator"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/graphicsview/padnavigator"
- SOURCES
- flippablepad.cpp flippablepad.h
- form.ui
- main.cpp
- padnavigator.cpp padnavigator.h
- roundrectitem.cpp roundrectitem.h
- splashitem.cpp splashitem.h
- PUBLIC_LIBRARIES
- Qt::Widgets
- ENABLE_AUTOGEN_TOOLS
- uic
-)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-# Resources:
-add_qt_resource(padnavigator "padnavigator" FILES
- images/artsfftscope.png
- images/blue_angle_swirl.jpg
- images/kontact_contacts.png
- images/kontact_journal.png
- images/kontact_mail.png
- images/kontact_notes.png
- images/kopeteavailable.png
- images/metacontact_online.png
- images/minitools.png)
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+set(INSTALL_EXAMPLEDIR "examples")
-#### Keys ignored in scope 1:.:.:padnavigator.pro:<TRUE>:
-# CONFIG = "console"
+find_package(Qt5 COMPONENTS Widgets)
+find_package(Qt5 COMPONENTS OpenGL) # special case
-## Scopes:
-#####################################################################
+add_executable(padnavigator
+ flippablepad.cpp flippablepad.h
+ form.ui
+ main.cpp
+ padnavigator.cpp padnavigator.h padnavigator.qrc
+ roundrectitem.cpp roundrectitem.h
+ splashitem.cpp splashitem.h
+)
+target_link_libraries(padnavigator PUBLIC
+ Qt::Widgets
+)
+# special case begin
+if (TARGET Qt::OpenGL)
+ target_link_libraries(padnavigator PUBLIC Qt::OpenGL)
+endif()
+# special case end
-extend_target(padnavigator CONDITION TARGET Qt::OpenGL
- PUBLIC_LIBRARIES
- Qt::OpenGL
+install(TARGETS padnavigator
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)