summaryrefslogtreecommitdiffstats
path: root/examples/widgets/mac/qmacnativewidget/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-06-26 14:01:45 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-06-26 15:10:26 +0200
commitcc857a3c716729610ef61fa075f8d360684dae09 (patch)
tree88b0fb69fa12405f92d4f04345c46a6473e2954d /examples/widgets/mac/qmacnativewidget/CMakeLists.txt
parentb043871d2b1ee9c57d75fe8a3f8cb22e35a4fe4d (diff)
macOS: Remove examples for deprecated QMac(NativeWidget|CocoaViewContainer)
Change-Id: I60d694f868623ed9761baf0cf532a87ab3412208 Reviewed-by: Timur Pocheptsov <timur.pocheptsov@qt.io>
Diffstat (limited to 'examples/widgets/mac/qmacnativewidget/CMakeLists.txt')
-rw-r--r--examples/widgets/mac/qmacnativewidget/CMakeLists.txt32
1 files changed, 0 insertions, 32 deletions
diff --git a/examples/widgets/mac/qmacnativewidget/CMakeLists.txt b/examples/widgets/mac/qmacnativewidget/CMakeLists.txt
deleted file mode 100644
index 5ed3e0f4cc..0000000000
--- a/examples/widgets/mac/qmacnativewidget/CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
-# Generated from qmacnativewidget.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(qmacnativewidget LANGUAGES CXX)
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
-
-set(INSTALL_EXAMPLEDIR "examples/widgets/mac/qmacnativewidget")
-
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
-
-add_qt_gui_executable(qmacnativewidget
- main.mm
-)
-target_link_libraries(qmacnativewidget PUBLIC
- "-framework AppKit"
- Qt::Core
- Qt::Gui
- Qt::Widgets
-)
-
-install(TARGETS qmacnativewidget
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)