summaryrefslogtreecommitdiffstats
path: root/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-10 18:31:58 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-10 18:35:07 +0100
commit3af9d49bb78ac56bff57d1c3867853730f97a8e1 (patch)
treec9d6c1d1fe90dba3c788fd06795cf05a6d4ed5bb /examples/widgets/mainwindows/mainwindow/CMakeLists.txt
parent71436d5499a9e0355f778f47ef465486a727049d (diff)
parentc431e2d33c2b13dee8b43a08c267c20ec1ae9654 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Diffstat (limited to 'examples/widgets/mainwindows/mainwindow/CMakeLists.txt')
-rw-r--r--examples/widgets/mainwindows/mainwindow/CMakeLists.txt24
1 files changed, 22 insertions, 2 deletions
diff --git a/examples/widgets/mainwindows/mainwindow/CMakeLists.txt b/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
index f4f8bdb4ca..3152fb0904 100644
--- a/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
+++ b/examples/widgets/mainwindows/mainwindow/CMakeLists.txt
@@ -9,20 +9,40 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/widgets/mainwindows/mainwindow")
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS Widgets)
add_qt_gui_executable(mainwindow
colorswatch.cpp colorswatch.h
main.cpp
- mainwindow.cpp mainwindow.h mainwindow.qrc
+ mainwindow.cpp mainwindow.h
toolbar.cpp toolbar.h
)
target_link_libraries(mainwindow PUBLIC
+ Qt::Core
+ Qt::Gui
Qt::Widgets
)
+
+# Resources:
+set(mainwindow_resource_files
+ "qt.png"
+ "titlebarCenter.png"
+ "titlebarLeft.png"
+ "titlebarRight.png"
+)
+
+qt6_add_resources(mainwindow "mainwindow"
+ PREFIX
+ "/res"
+ FILES
+ ${mainwindow_resource_files}
+)
+
install(TARGETS mainwindow
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"