summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/painterpaths/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-11-21 12:03:41 +0100
committerKai Köhne <kai.koehne@qt.io>2022-11-30 14:48:50 +0100
commita5de12f0d7dfef64453b7b29c33dc760b3cacec4 (patch)
treec55549f8c325eb0a3a3eb09c5ac76a31d763fdbd /examples/widgets/painting/painterpaths/CMakeLists.txt
parentd221ea609fdd9f5dc99f520391beddc057373278 (diff)
Examples: Use PRIVATE CMake linkage
We (almost) only build apps, for which PRIVATE linkage makes more sense. Change-Id: I09a509c3fb33a00cdfdede687b3f95d638f42091 Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/widgets/painting/painterpaths/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/painterpaths/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/widgets/painting/painterpaths/CMakeLists.txt b/examples/widgets/painting/painterpaths/CMakeLists.txt
index 280953d503..0a701d82ab 100644
--- a/examples/widgets/painting/painterpaths/CMakeLists.txt
+++ b/examples/widgets/painting/painterpaths/CMakeLists.txt
@@ -25,14 +25,14 @@ set_target_properties(painterpaths PROPERTIES
MACOSX_BUNDLE TRUE
)
-target_link_libraries(painterpaths PUBLIC
+target_link_libraries(painterpaths PRIVATE
Qt6::Core
Qt6::Gui
Qt6::Widgets
)
if(UNIX AND NOT APPLE AND NOT HAIKU AND NOT INTEGRITY AND NOT VXWORKS)
- target_link_libraries(painterpaths PUBLIC
+ target_link_libraries(painterpaths PRIVATE
m
)
endif()