summaryrefslogtreecommitdiffstats
path: root/examples/widgets/painting/shared/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-11-14 14:49:32 +0100
committerKai Köhne <kai.koehne@qt.io>2022-11-17 19:59:11 +0100
commitbec264c15fe07382009def3c4bbef3f3b689b6eb (patch)
tree2335b779fc09463522ff5356cd2c152ff64d603f /examples/widgets/painting/shared/CMakeLists.txt
parent9e251d44a79e171f093e89b21215d7372866ef4c (diff)
Examples: Use Qt6:: to qualify Qt CMake packages
This is what we promote also in the documentation. Change-Id: If91aebafe861b0c934acbb2c69afd182abc3345d Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/widgets/painting/shared/CMakeLists.txt')
-rw-r--r--examples/widgets/painting/shared/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/widgets/painting/shared/CMakeLists.txt b/examples/widgets/painting/shared/CMakeLists.txt
index 48fca30029..f3d6fd49de 100644
--- a/examples/widgets/painting/shared/CMakeLists.txt
+++ b/examples/widgets/painting/shared/CMakeLists.txt
@@ -11,16 +11,16 @@ target_sources(painting_shared PRIVATE
${moc_files}
)
-target_link_libraries(painting_shared PUBLIC Qt::Widgets)
+target_link_libraries(painting_shared PUBLIC Qt6::Widgets)
target_include_directories(painting_shared PUBLIC "${CMAKE_CURRENT_SOURCE_DIR}")
## Scopes:
#####################################################################
-if (TARGET Qt::OpenGL OR QT_FEATURE_opengles2)
+if (TARGET Qt6::OpenGL OR QT_FEATURE_opengles2)
target_compile_definitions(painting_shared PRIVATE QT_OPENGL_SUPPORT)
target_link_libraries(painting_shared PUBLIC
- Qt::OpenGL
+ Qt6::OpenGL
)
qt6_wrap_cpp(moc_files_gl fbopaintdevice.h) # no automoc for OBJECT libs
target_sources(painting_shared PRIVATE fbopaintdevice.cpp fbopaintdevice.h ${moc_files_gl})