summaryrefslogtreecommitdiffstats
path: root/examples/widgets/richtext/textedit/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-28 16:41:49 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-06-03 15:14:42 +0200
commite4079eca49adce16e31dac2a18d49d7a55817891 (patch)
tree1dfb960ec1115b1f552afe8a013058542389505e /examples/widgets/richtext/textedit/CMakeLists.txt
parentf32a6cfb6b6236533508901f114ab57396da8ff3 (diff)
parentec6dc5f78453048c4f0604655a34c6c20c79d819 (diff)
Merge remote-tracking branch 'origin/dev' into wip/cmake
Diffstat (limited to 'examples/widgets/richtext/textedit/CMakeLists.txt')
-rw-r--r--examples/widgets/richtext/textedit/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/examples/widgets/richtext/textedit/CMakeLists.txt b/examples/widgets/richtext/textedit/CMakeLists.txt
index 9166f6748a..487f708b34 100644
--- a/examples/widgets/richtext/textedit/CMakeLists.txt
+++ b/examples/widgets/richtext/textedit/CMakeLists.txt
@@ -11,7 +11,7 @@ add_qt_executable(textedit
SOURCES
main.cpp
textedit.cpp textedit.h
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::Widgets
)
@@ -19,6 +19,8 @@ add_qt_executable(textedit
add_qt_resource(textedit "textedit" PREFIX "/" FILES
example.html
images/logo32.png
+ images/mac/checkbox-checked.png
+ images/mac/checkbox.png
images/mac/editcopy.png
images/mac/editcut.png
images/mac/editpaste.png
@@ -29,6 +31,8 @@ add_qt_resource(textedit "textedit" PREFIX "/" FILES
images/mac/fileopen.png
images/mac/fileprint.png
images/mac/filesave.png
+ images/mac/format-indent-less.png
+ images/mac/format-indent-more.png
images/mac/textbold.png
images/mac/textcenter.png
images/mac/textitalic.png
@@ -38,6 +42,8 @@ add_qt_resource(textedit "textedit" PREFIX "/" FILES
images/mac/textunder.png
images/mac/zoomin.png
images/mac/zoomout.png
+ images/win/checkbox-checked.png
+ images/win/checkbox.png
images/win/editcopy.png
images/win/editcut.png
images/win/editpaste.png
@@ -48,6 +54,8 @@ add_qt_resource(textedit "textedit" PREFIX "/" FILES
images/win/fileopen.png
images/win/fileprint.png
images/win/filesave.png
+ images/win/format-indent-less.png
+ images/win/format-indent-more.png
images/win/textbold.png
images/win/textcenter.png
images/win/textitalic.png
@@ -59,7 +67,7 @@ add_qt_resource(textedit "textedit" PREFIX "/" FILES
images/win/zoomout.png)
-#### Keys ignored in scope 1:.:textedit.pro:<NONE>:
+#### Keys ignored in scope 1:.:.:textedit.pro:<TRUE>:
# EXAMPLE_FILES = "textedit.qdoc"
# TEMPLATE = "app"
@@ -67,9 +75,9 @@ add_qt_resource(textedit "textedit" PREFIX "/" FILES
#####################################################################
extend_target(textedit CONDITION TARGET Qt::PrintSupport
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::PrintSupport
)
-#### Keys ignored in scope 3:.:textedit.pro:build_all AND NOT build_pass:
+#### Keys ignored in scope 3:.:.:textedit.pro:build_all AND NOT build_pass:
# CONFIG = "-build_all" "release"