summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/echoplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2022-07-26 16:00:52 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2022-07-27 16:37:54 +0200
commit818a15234c8fb80cd9adad54bd726cf69726fa79 (patch)
tree0ec6ddc3c2e65a999cd0418845db71691363dd38 /examples/widgets/tools/echoplugin/CMakeLists.txt
parent22c3b87b14cfc5cf38463d641f122cff31fb757e (diff)
CMake: Make sure qtbase examples are installed into the correct path
The find_package calls need to happen after we set INSTALL_EXAMPLEDIR to ensure that INSTALL_EXAMPLEDIR is overridden if necessary. Pick-to: 6.2 6.3 6.4 Task-number: QTBUG-102879 Change-Id: I3c2e6c5a68a8c6ff9b98b79dbd6c83445d8da052 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'examples/widgets/tools/echoplugin/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/echoplugin/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/examples/widgets/tools/echoplugin/CMakeLists.txt b/examples/widgets/tools/echoplugin/CMakeLists.txt
index 93b49b43d7..c0b50033e0 100644
--- a/examples/widgets/tools/echoplugin/CMakeLists.txt
+++ b/examples/widgets/tools/echoplugin/CMakeLists.txt
@@ -1,8 +1,6 @@
cmake_minimum_required(VERSION 3.16)
project(plugandpaint LANGUAGES CXX)
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
set(CMAKE_AUTOMOC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
@@ -11,5 +9,7 @@ endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/tools/echoplugin")
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
add_subdirectory(plugin)
add_subdirectory(echowindow)