summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-26 15:06:29 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-30 08:50:59 +0200
commit9c71b924304c2d1bd3ac3e13263b47131478562c (patch)
tree5fcf6878f4143518c18e3cdb564c90323104935e /examples/widgets/tools/plugandpaint/app/CMakeLists.txt
parent921337f98c54d3c4a252569acd2152a1dea8c4bb (diff)
Move plug and paint example to manual test
Pick-to: 6.5 6.6 Change-Id: Ibfd870f2f879d6ae68cd6806b0c1ab02da0a3441 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/widgets/tools/plugandpaint/app/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/app/CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/examples/widgets/tools/plugandpaint/app/CMakeLists.txt b/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
deleted file mode 100644
index c0368e7ba2..0000000000
--- a/examples/widgets/tools/plugandpaint/app/CMakeLists.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-qt_add_executable(plugandpaint
- interfaces.h
- main.cpp
- mainwindow.cpp mainwindow.h
- paintarea.cpp paintarea.h
- plugindialog.cpp plugindialog.h
-)
-
-set_target_properties(plugandpaint PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(plugandpaint PRIVATE
- Qt6::Widgets
- pnp_basictools
-)
-
-if(QT6_IS_SHARED_LIBS_BUILD)
- # Build the shared plugin too when building this example target.
- add_dependencies(plugandpaint pnp_extrafilters)
-else()
- # Link the extrafilters plugin if Qt is built statically.
- target_link_libraries(plugandpaint PRIVATE
- pnp_extrafilters
- )
-endif()
-
-install(TARGETS plugandpaint
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)