summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-26 13:32:34 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-27 14:35:46 +0000
commit72404ef3e1e5ad3513986308d26f4af48ba9d28d (patch)
tree50634a21b450a41f8ba1da3930535b0283063578 /examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
parent9ba702bea9c12b45c746cac53d843717162545e1 (diff)
CMake: allow custom plugin output/install directories
Only require TYPE if no OUTPUT_DIRECTORY, ARCHIVE_INSTALL_DIRECTORY and INSTALL_DIRECTORY is provided. Change-Id: I6db1cfaa576bfa3ee3dc8ecf81db20e3afcd61e2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt b/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
index f736d09d41..a059d0deab 100644
--- a/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
+++ b/examples/widgets/tools/plugandpaint/plugins/basictools/CMakeLists.txt
@@ -8,6 +8,7 @@ add_qt_plugin(pnp_basictools # special case
STATIC # special case
OUTPUT_DIRECTORY ../../plugins # special case
INSTALL_DIRECTORY ../../plugins # special case
+ ARCHIVE_INSTALL_DIRECTORY ../../plugins # special case
SOURCES
basictoolsplugin.cpp basictoolsplugin.h
INCLUDE_DIRECTORIES