summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tools/styleplugin/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2023-12-21 11:00:33 +0100
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2023-12-21 18:38:01 +0100
commit5a0135fafb16203a812163f7ed55c1b981477cb5 (patch)
tree4ff69d44d838fd4f796bf64acf6d812df696c038 /examples/widgets/tools/styleplugin/CMakeLists.txt
parentf83e14b13a32b2cddff45dfdbce8e819c02aa9ca (diff)
Remove the style plugin example
The snippets in the QStylePlugin class documentation show the relevant bits well enough. Pick-to: 6.7 6.6 Fixes: QTBUG-119974 Change-Id: Iba4a37664d64d86a2946f41d131a201ccdcd723b Reviewed-by: Axel Spoerl <axel.spoerl@qt.io>
Diffstat (limited to 'examples/widgets/tools/styleplugin/CMakeLists.txt')
-rw-r--r--examples/widgets/tools/styleplugin/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/examples/widgets/tools/styleplugin/CMakeLists.txt b/examples/widgets/tools/styleplugin/CMakeLists.txt
deleted file mode 100644
index 7e46a7b2af..0000000000
--- a/examples/widgets/tools/styleplugin/CMakeLists.txt
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(styleplugin LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/tools/styleplugin")
-
-find_package(Qt6 REQUIRED COMPONENTS Widgets)
-
-qt_standard_project_setup()
-
-add_subdirectory(stylewindow)
-add_subdirectory(plugin)