summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tutorials/addressbook/part6/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2023-05-15 12:08:45 +0200
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2023-05-15 14:52:17 +0200
commitf4b338833e0222db68f37914ecfa21ff11fd718a (patch)
tree31e7a00f2aed603ea15307e6cee66fd070994db8 /examples/widgets/tutorials/addressbook/part6/CMakeLists.txt
parenta035e8b76835764924f59ae4610e648875e3e7a6 (diff)
Move the addressbook tutorial into manual tests
The tutorial is building an elaborate UI around a QMap. It doesn't use structured data, and it doesn't use model/view (which the dedicated addressbook example in itemviews does). It's not a good way of building an application, and the individual APIs for creating layouts, dialogs, or import/export are explained well enough in other examples. Pick-to: 6.5 Change-Id: Iffe47a0f6e04a933edb917c877ae845f50b74b4a Reviewed-by: Axel Spoerl <axel.spoerl@qt.io>
Diffstat (limited to 'examples/widgets/tutorials/addressbook/part6/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/addressbook/part6/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/examples/widgets/tutorials/addressbook/part6/CMakeLists.txt b/examples/widgets/tutorials/addressbook/part6/CMakeLists.txt
deleted file mode 100644
index 8e954c51ab..0000000000
--- a/examples/widgets/tutorials/addressbook/part6/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(part6 LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/tutorials/addressbook/part6")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
-qt_standard_project_setup()
-
-qt_add_executable(part6
- addressbook.cpp addressbook.h
- finddialog.cpp finddialog.h
- main.cpp
-)
-
-set_target_properties(part6 PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(part6 PRIVATE
- Qt6::Core
- Qt6::Gui
- Qt6::Widgets
-)
-
-install(TARGETS part6
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)