summaryrefslogtreecommitdiffstats
path: root/examples/widgets/tutorials/notepad/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-22 16:23:24 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-22 14:58:24 +0000
commitfa21d29b7506e21db8a433e117aebb9f3c724f03 (patch)
tree948fda13d49223bef78f982e6f67a140e4df6907 /examples/widgets/tutorials/notepad/CMakeLists.txt
parent0425ee06102410026f436adfd440aa2f0b3efd61 (diff)
Rerun pro2cmake on projects that use .ui files
Task-number: QTBUG-75875 Change-Id: I95109b07fc4a6e09fe7911a21fc5f27f2c895d77 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'examples/widgets/tutorials/notepad/CMakeLists.txt')
-rw-r--r--examples/widgets/tutorials/notepad/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/examples/widgets/tutorials/notepad/CMakeLists.txt b/examples/widgets/tutorials/notepad/CMakeLists.txt
index 9dcf98fe4c..d34d3ca846 100644
--- a/examples/widgets/tutorials/notepad/CMakeLists.txt
+++ b/examples/widgets/tutorials/notepad/CMakeLists.txt
@@ -11,8 +11,10 @@ add_qt_executable(notepad
SOURCES
main.cpp
notepad.cpp notepad.h notepad.ui
+ ENABLE_AUTOGEN_TOOLS
+ uic
LIBRARIES # special case
- Qt::Widgets
+ Qt::Widgets # special case
)
# Resources:
@@ -37,13 +39,13 @@ add_qt_resource(notepad "notepad" PREFIX "/" FILES
images/underline.png)
-#### Keys ignored in scope 1:.:notepad.pro:<NONE>:
+#### Keys ignored in scope 1:.:.:notepad.pro:<TRUE>:
# TEMPLATE = "app"
## Scopes:
#####################################################################
extend_target(notepad CONDITION TARGET Qt::PrintSupport
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::PrintSupport
)