summaryrefslogtreecommitdiffstats
path: root/examples/widgets/widgets/movie/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-26 14:59:25 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2023-06-28 14:05:41 +0200
commitec01f6ae8b28f6b5cdb125e8e42e18b96f2a97a6 (patch)
tree1ce77d706629eb8830351e96d447bd10525ff994 /examples/widgets/widgets/movie/CMakeLists.txt
parentc7702638f33b78c39981504574db5021e1d7c383 (diff)
Move movie example to manual test
Pick-to: 6.5 6.6 Change-Id: Ie185a3c88eced7b8b0fe324b9ef62ab86d38d521 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/widgets/widgets/movie/CMakeLists.txt')
-rw-r--r--examples/widgets/widgets/movie/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/examples/widgets/widgets/movie/CMakeLists.txt b/examples/widgets/widgets/movie/CMakeLists.txt
deleted file mode 100644
index f5165e15f6..0000000000
--- a/examples/widgets/widgets/movie/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(movie LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/widgets/movie")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
-qt_standard_project_setup()
-
-qt_add_executable(movie
- main.cpp
- movieplayer.cpp movieplayer.h
-)
-
-set_target_properties(movie PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(movie PRIVATE
- Qt6::Core
- Qt6::Gui
- Qt6::Widgets
-)
-
-install(TARGETS movie
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)