summaryrefslogtreecommitdiffstats
path: root/examples/widgets/widgets/wiggly/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Arve Sæther <jan-arve.saether@qt.io>2023-01-17 11:02:29 +0100
committerJan Arve Sæther <jan-arve.saether@qt.io>2023-01-31 22:28:30 +0100
commite08575a18ace251161cc813cfe48db68b8b15eee (patch)
tree6c8743dc52d58f6a192f4932648dafa46b5eaef7 /examples/widgets/widgets/wiggly/CMakeLists.txt
parent2db2eb600ad860e3822605990e731841a5e86e97 (diff)
Remove wiggly example
It demonstrates timerEvent() and some QFontMetrics There are other examples that demonstrates this Pick-to: 6.5 Change-Id: I4ad6f30c8ef93c995f980545ed88ab13b9aa9c7d Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'examples/widgets/widgets/wiggly/CMakeLists.txt')
-rw-r--r--examples/widgets/widgets/wiggly/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/examples/widgets/widgets/wiggly/CMakeLists.txt b/examples/widgets/widgets/wiggly/CMakeLists.txt
deleted file mode 100644
index c529c20bfa..0000000000
--- a/examples/widgets/widgets/wiggly/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright (C) 2022 The Qt Company Ltd.
-# SPDX-License-Identifier: BSD-3-Clause
-
-cmake_minimum_required(VERSION 3.16)
-project(wiggly LANGUAGES CXX)
-
-if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
-endif()
-
-set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/widgets/widgets/wiggly")
-
-find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
-
-qt_standard_project_setup()
-
-qt_add_executable(wiggly
- dialog.cpp dialog.h
- main.cpp
- wigglywidget.cpp wigglywidget.h
-)
-
-set_target_properties(wiggly PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-
-target_link_libraries(wiggly PRIVATE
- Qt6::Core
- Qt6::Gui
- Qt6::Widgets
-)
-
-install(TARGETS wiggly
- RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
- BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
- LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
-)