summaryrefslogtreecommitdiffstats
path: root/examples/widgets/windowcontainer/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-06-04 17:08:47 +0200
committerKevin Funk <kevin.funk@kdab.com>2019-06-05 12:53:28 +0000
commit99539a289491a2a709c2a63cd91eac155a1699da (patch)
treed928d6c6e123c6588261bea9358354fe1e1a7400 /examples/widgets/windowcontainer/CMakeLists.txt
parentace549587073d387823815b02ec85a28da408844 (diff)
Allow to build examples as standalone project
Create CMake config files which can be used from the very same CMake project. These CMake config files simply do not create any targets, controlled via the QT_NO_CREATE_TARGETS. This patch also allows to build qtbase.git:examples as a standalone project, against an already-built Qt. Ran this: ag -s "QT " examples -l -0 | xargs -0 -n 1 .../util/cmake/pro2cmake.py --is-example Task-number: QTBUG-74713 Change-Id: I44cce5a4048618b30f890c5b789592c227a8b47d Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/widgets/windowcontainer/CMakeLists.txt')
-rw-r--r--examples/widgets/windowcontainer/CMakeLists.txt40
1 files changed, 26 insertions, 14 deletions
diff --git a/examples/widgets/windowcontainer/CMakeLists.txt b/examples/widgets/windowcontainer/CMakeLists.txt
index 88dc37ea5e..f67a6515bd 100644
--- a/examples/widgets/windowcontainer/CMakeLists.txt
+++ b/examples/widgets/windowcontainer/CMakeLists.txt
@@ -1,18 +1,30 @@
# Generated from windowcontainer.pro.
-#####################################################################
-## windowcontainer Binary:
-#####################################################################
+cmake_minimum_required(VERSION 3.14)
+project(windowcontainer LANGUAGES CXX)
-add_qt_executable(windowcontainer
- GUI
- OUTPUT_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/windowcontainer"
- INSTALL_DIRECTORY "${INSTALL_EXAMPLESDIR}/widgets/windowcontainer"
- SOURCES
- ../../gui/openglwindow/openglwindow.cpp ../../gui/openglwindow/openglwindow.h
- windowcontainer.cpp
- INCLUDE_DIRECTORIES
- ../../gui/openglwindow
- LIBRARIES
- Qt::Widgets
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt5 COMPONENTS Widgets)
+
+add_executable(windowcontainer WIN32 MACOSX_BUNDLE
+ ../../gui/openglwindow/openglwindow.cpp ../../gui/openglwindow/openglwindow.h
+ windowcontainer.cpp
+)
+target_include_directories(windowcontainer PUBLIC
+ ../../gui/openglwindow
+)
+target_link_libraries(windowcontainer PUBLIC
+ Qt::Widgets
+)
+
+install(TARGETS windowcontainer
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
)