summaryrefslogtreecommitdiffstats
path: root/examples/xml/xmlstreamlint/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 08:15:50 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-04 18:50:39 +0000
commit76108058796bf0884f6fd128d81f1bc49f9a56af (patch)
tree1c5f0740ca3217f3d11cf7c684143bbb0da0f336 /examples/xml/xmlstreamlint/CMakeLists.txt
parent465949420a877099247d94dd4db54d19ca5a9a7c (diff)
Regenerate examples
Change-Id: I04b2adbe370ffea81d7787ad90e4ae69d2c165cb Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/xml/xmlstreamlint/CMakeLists.txt')
-rw-r--r--examples/xml/xmlstreamlint/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/examples/xml/xmlstreamlint/CMakeLists.txt b/examples/xml/xmlstreamlint/CMakeLists.txt
index d12b549996..b100943537 100644
--- a/examples/xml/xmlstreamlint/CMakeLists.txt
+++ b/examples/xml/xmlstreamlint/CMakeLists.txt
@@ -3,15 +3,15 @@
cmake_minimum_required(VERSION 3.14)
project(xmlstreamlint LANGUAGES CXX)
-find_package(Qt6 COMPONENTS Core Xml) # special case: add
-
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples")
+set(INSTALL_EXAMPLEDIR "examples/xml/xmlstreamlint")
+
+find_package(Qt6 COMPONENTS Core Xml) # special case
add_executable(xmlstreamlint
main.cpp
@@ -20,6 +20,7 @@ target_link_libraries(xmlstreamlint PUBLIC
Qt::Core
Qt::Xml # special case: add
)
+
install(TARGETS xmlstreamlint
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"