summaryrefslogtreecommitdiffstats
path: root/qmake/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2020-04-03 11:49:27 +0200
committerLars Knoll <lars.knoll@qt.io>2020-05-05 18:41:10 +0200
commit52f3a7d9d40d3bf835bb0716ad201ee56731b980 (patch)
treea736d2cca2516f2ad2003ff28b34e7a8ff483cf6 /qmake/CMakeLists.txt
parentae7e701074be97130aa45f780e2456981850b432 (diff)
Build qmake with QT_USE_STRINGBUILDER
Should improve performance and is going to be required in the future anyway. Change-Id: I89d7c50441d2491da1ab0a4d564dcc91f52ade85 Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'qmake/CMakeLists.txt')
-rw-r--r--qmake/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/qmake/CMakeLists.txt b/qmake/CMakeLists.txt
index 3bfd27f293..7017812aca 100644
--- a/qmake/CMakeLists.txt
+++ b/qmake/CMakeLists.txt
@@ -72,6 +72,7 @@ qt_add_tool(qmake # special case
../src/corelib/text/qregexp.cpp ../src/corelib/text/qregexp.h
../src/corelib/tools/qringbuffer.cpp # special case
../src/corelib/text/qstring.cpp ../src/corelib/text/qstring.h
+ ../src/corelib/text/qstringbuilder.cpp ../src/corelib/text/qstringbuilder.h
../src/corelib/text/qstringlist.cpp ../src/corelib/text/qstringlist.h
../src/corelib/text/qstringmatcher.h
../src/corelib/tools/qvector.h
@@ -110,6 +111,7 @@ qt_add_tool(qmake # special case
PROEVALUATOR_FULL
QT_BOOTSTRAPPED
QT_BUILD_QMAKE
+ QT_USE_QSTRINGBUILDER
QT_NO_FOREACH
QT_VERSION_STR="${PROJECT_VERSION}" # special case
QT_VERSION_MAJOR=${PROJECT_VERSION_MAJOR} # special case