summaryrefslogtreecommitdiffstats
path: root/qmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-03-09 16:32:02 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2021-03-12 13:20:00 +0100
commit5db85796206666bea8c47ea1a0c1cdb2fa863ffc (patch)
tree0bca21c20f78ff5659daead85dda36a67ed5b011 /qmake/CMakeLists.txt
parentf0862c08f1a15baff20bca1d4c0fd9f331671b46 (diff)
Add support for various output formats for QMakeProperty
Add the ability to select a standard and json output formats of the Qt properties. This patch also improves the encapsulation of QMakeProperty. Change-Id: Ib1d232be1b430ed8456ce65cc98141282e4c3f7f Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'qmake/CMakeLists.txt')
-rw-r--r--qmake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/qmake/CMakeLists.txt b/qmake/CMakeLists.txt
index 0a49c9db79..b89cf25f10 100644
--- a/qmake/CMakeLists.txt
+++ b/qmake/CMakeLists.txt
@@ -9,6 +9,7 @@ add_library(QtLibraryInfo OBJECT
library/proitems.cpp library/proitems.h
library/qmake_global.h
property.cpp property.h
+ propertyprinter.cpp propertyprinter.h
qmakelibraryinfo.cpp qmakelibraryinfo.h
)
set_target_properties(QtLibraryInfo PROPERTIES