summaryrefslogtreecommitdiffstats
path: root/qmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2023-06-07 07:41:52 +0000
committerAlexandru Croitor <alexandru.croitor@qt.io>2023-06-08 11:04:45 +0000
commite3c6754760b23a9d6e7879c037f72bf768674572 (patch)
tree20a4e9fff5157ed81dcc827b40c7bdf5fbab8506 /qmake/CMakeLists.txt
parent788b400d0eefc314d4bfd84baf849b07c6fa9772 (diff)
Revert "CMake: make compile options consistent for Qt created libraries"
This reverts commit 389507a047e0ec0721535052df6ddf957fbb95b3. Reason for revert: The original patch unintentionally changes the deprecation warning behavior for user projects. Merging the current change will resurface the original static qt build bug until a new fix is developed. Pick-to: 6.6 Change-Id: I29b41b43fdd76b19bc46439470e04443dc2b8ddb Reviewed-by: Alexey Edelev <alexey.edelev@qt.io> Reviewed-by: Yuhang Zhao <yuhangzhao@deepin.org>
Diffstat (limited to 'qmake/CMakeLists.txt')
-rw-r--r--qmake/CMakeLists.txt18
1 files changed, 12 insertions, 6 deletions
diff --git a/qmake/CMakeLists.txt b/qmake/CMakeLists.txt
index abd9c84cc9..0a10dd5dd2 100644
--- a/qmake/CMakeLists.txt
+++ b/qmake/CMakeLists.txt
@@ -16,14 +16,14 @@ qt_add_library(QtLibraryInfo OBJECT
qmakelibraryinfo.cpp qmakelibraryinfo.h
)
-# Make sure we use same parameters when building QtLibraryInfo and other Qt libraries,
-# otherwise some compilers may have compilation errors, such as clang-cl.
-target_link_libraries(QtLibraryInfo PUBLIC PlatformCommonInternal)
-
-target_link_libraries(QtLibraryInfo PUBLIC Qt::CorePrivate)
-
qt_internal_add_sync_header_dependencies(QtLibraryInfo Core)
+set_target_properties(QtLibraryInfo PROPERTIES
+ COMPILE_OPTIONS $<TARGET_PROPERTY:Qt::Core,INTERFACE_COMPILE_OPTIONS>
+ COMPILE_DEFINITIONS $<TARGET_PROPERTY:Qt::Core,INTERFACE_COMPILE_DEFINITIONS>
+ INCLUDE_DIRECTORIES $<TARGET_PROPERTY:Qt::Core,INTERFACE_INCLUDE_DIRECTORIES>
+ INCLUDE_DIRECTORIES $<TARGET_PROPERTY:Qt::CorePrivate,INTERFACE_INCLUDE_DIRECTORIES>
+)
target_include_directories(QtLibraryInfo PUBLIC
"${CMAKE_CURRENT_SOURCE_DIR}"
"${CMAKE_CURRENT_SOURCE_DIR}/library"
@@ -35,13 +35,18 @@ if("${hostdatadir}" STREQUAL "")
set(hostdatadir ".")
endif()
+qt_internal_library_deprecation_level(deprecation_define)
+
target_compile_definitions(QtLibraryInfo PUBLIC
PROEVALUATOR_FULL
QT_BUILD_QMAKE
QT_USE_QSTRINGBUILDER
+ QT_NO_FOREACH
+ QT_VERSION_STR="${PROJECT_VERSION}"
QT_HOST_MKSPEC="${QT_QMAKE_HOST_MKSPEC}"
QT_TARGET_MKSPEC="${QT_QMAKE_TARGET_MKSPEC}"
QT_HOST_DATADIR="${hostdatadir}"
+ ${deprecation_define}
)
qt_internal_set_exceptions_flags(QtLibraryInfo OFF)
@@ -95,6 +100,7 @@ qt_internal_add_tool(${target_name}
PRECOMPILED_HEADER
"qmake_pch.h"
LIBRARIES
+ Qt::CorePrivate
QtLibraryInfo
)
qt_internal_return_unless_building_tools()