summaryrefslogtreecommitdiffstats
path: root/qmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-17 09:54:59 +0100
committerLeander Beernaert <leander.beernaert@qt.io>2020-02-18 14:44:57 +0100
commiteaa29378b9009e36f643004e2df5265cc63409f6 (patch)
treef3ae00b3202c3b1d188db3067f242809ad915743 /qmake/CMakeLists.txt
parent00eeed234f7c4cfc357b17424e0dcd714ff65e70 (diff)
CMake: Fix c++ standard config tests with MSVC
Need to pass additional -Zc:__cplusplus flag when using MSVC, so that the __cplusplus define has correct values. Additionally make the option be propagated to consumers of Qt via the public Platform target, which QtCore links against. Change-Id: Ie1283c25334b93f993529beb7fb32bdb001627f5 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Leander Beernaert <leander.beernaert@qt.io>
Diffstat (limited to 'qmake/CMakeLists.txt')
-rw-r--r--qmake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/qmake/CMakeLists.txt b/qmake/CMakeLists.txt
index ff50f507c5..fb370eda4a 100644
--- a/qmake/CMakeLists.txt
+++ b/qmake/CMakeLists.txt
@@ -215,3 +215,6 @@ set_target_properties(qmake PROPERTIES
)
qt_internal_add_link_flags_gc_sections(qmake PRIVATE) # special case
+
+qt_enable_msvc_cplusplus_define(qmake PUBLIC) # special case
+