summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/harfbuzz/tests/shaping/Makefile.am
diff options
context:
space:
mode:
authorKonstantin Ritt <ritt.ks@gmail.com>2012-05-10 10:31:16 +0300
committerQt by Nokia <qt-info@nokia.com>2012-05-10 11:34:25 +0200
commitcbfdec66033d14020d3e8a49bacc0d12d2b6798e (patch)
tree02e94eaad62c85f1556623b17412607102f067cb /src/3rdparty/harfbuzz/tests/shaping/Makefile.am
parent8c0048a377568b646b3b87be0b02322fce68b780 (diff)
move the default text breaking algorithm impl from HarfBuzz to Qt
there are several reasons to do this: * text breaking is not a shaper's job; * since the text breaking rules are bound to a specific Unicode version, updating Qt's internal unicode data would require updating the data in HB as well; * makes porting to HurfBuzz-NG some easier Change-Id: I0bbf8e8a343bc074696f4ddf2ae4e7fa32a61629 Reviewed-by: Lars Knoll <lars.knoll@nokia.com>
Diffstat (limited to 'src/3rdparty/harfbuzz/tests/shaping/Makefile.am')
-rw-r--r--src/3rdparty/harfbuzz/tests/shaping/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/3rdparty/harfbuzz/tests/shaping/Makefile.am b/src/3rdparty/harfbuzz/tests/shaping/Makefile.am
index 31c6db73b4..5a7da0abf3 100644
--- a/src/3rdparty/harfbuzz/tests/shaping/Makefile.am
+++ b/src/3rdparty/harfbuzz/tests/shaping/Makefile.am
@@ -1,7 +1,7 @@
check_PROGRAMS = shaping
-shaping_SOURCES = main.cpp ../linebreaking/harfbuzz-qt.cpp
+shaping_SOURCES = main.cpp harfbuzz-qt.cpp
shaping_LDADD = $(QT_GUI_LIBS) $(QT_QTEST_LIBS) ../../src/libharfbuzz-1.la
main.o: main.moc