summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/pcre2/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-07-10 18:37:29 +0200
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-07-10 23:34:33 +0000
commit2f8df4d1a87df9dd67913b016171dac20839d16e (patch)
tree44632244c68d188ed2a11e4dc6a1fcbcfabe716e /src/3rdparty/pcre2/CMakeLists.txt
parente80be8a43da78b9544f12fbac47e92c7f1f64366 (diff)
Disable PCRE2 JIT on macOS ARM64
It's already disabled for many other ARM platforms, and upstream support for Apple Silicon is still pending, so we disable it for now. See: https://bugs.exim.org/show_bug.cgi?id=2618 Fixes: QTBUG-85528 Pick-to: 5.15 Pick-to: 5.12 Change-Id: I42b6e5efaa07c9b832cd05a47436eb86a214e9bf Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
Diffstat (limited to 'src/3rdparty/pcre2/CMakeLists.txt')
-rw-r--r--src/3rdparty/pcre2/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/3rdparty/pcre2/CMakeLists.txt b/src/3rdparty/pcre2/CMakeLists.txt
index 22291cabed..575424c887 100644
--- a/src/3rdparty/pcre2/CMakeLists.txt
+++ b/src/3rdparty/pcre2/CMakeLists.txt
@@ -67,12 +67,17 @@ qt_extend_target(BundledPcre2 CONDITION (TEST_architecture_arch STREQUAL "arm64"
PCRE2_DISABLE_JIT
)
+qt_extend_target(BundledPcre2 CONDITION MACOS AND (TEST_architecture_arch STREQUAL "arm64")
+ DEFINES
+ PCRE2_DISABLE_JIT
+)
+
qt_extend_target(BundledPcre2 CONDITION WIN32
PUBLIC_DEFINES
PCRE2_STATIC
)
-#### Keys ignored in scope 7:.:.:pcre2.pri:QT_FEATURE_intelcet:
+#### Keys ignored in scope 8:.:.:pcre2.pri:QT_FEATURE_intelcet:
# QMAKE_CFLAGS = "$$QMAKE_CFLAGS_SHSTK"
# special case begin