summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/pcre2/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2020-03-26 13:01:36 +0100
committerLars Knoll <lars.knoll@qt.io>2020-04-13 09:40:09 +0200
commit33752a9bd334a53e891f141afd2357eefb1a9a36 (patch)
treeadf44eafe1d4201b49088d3d8592c0b83877101a /src/3rdparty/pcre2/CMakeLists.txt
parentce1d4d362881b54ff774b49f54ef686f9aa97c73 (diff)
Include QRegularExpression in the bootstrap library
This allows us to use regular expressions in bootstrapped tools such as moc and tracegen. Change-Id: I4310dd15bf26651aac6ab30c884e025ca06b3099 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/3rdparty/pcre2/CMakeLists.txt')
-rw-r--r--src/3rdparty/pcre2/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/3rdparty/pcre2/CMakeLists.txt b/src/3rdparty/pcre2/CMakeLists.txt
index d32073dab5..b73f0bff9e 100644
--- a/src/3rdparty/pcre2/CMakeLists.txt
+++ b/src/3rdparty/pcre2/CMakeLists.txt
@@ -51,11 +51,6 @@ qt_set_symbol_visibility_hidden(BundledPcre2)
## Scopes:
#####################################################################
-qt_extend_target(BundledPcre2 CONDITION WIN32
- PUBLIC_DEFINES
- PCRE2_STATIC
-)
-
qt_extend_target(BundledPcre2 CONDITION QNX OR UIKIT OR WINRT
DEFINES
PCRE2_DISABLE_JIT
@@ -70,3 +65,8 @@ qt_extend_target(BundledPcre2 CONDITION (TEST_architecture_arch STREQUAL "arm64"
DEFINES
PCRE2_DISABLE_JIT
)
+
+qt_extend_target(BundledPcre2 CONDITION WIN32
+ PUBLIC_DEFINES
+ PCRE2_STATIC
+)