summaryrefslogtreecommitdiffstats
path: root/src/3rdparty/zlib/CMakeLists.txt
diff options
context:
space:
mode:
authorAmir Masoud Abdol <amir.abdol@qt.io>2023-03-09 14:55:58 +0100
committerAmir Masoud Abdol <amir.abdol@qt.io>2023-03-14 17:28:44 +0100
commitcfed6587476712b67d9de3fd67d708651d827690 (patch)
tree8ea07f1a8fae06cc801b522a1093981792fece11 /src/3rdparty/zlib/CMakeLists.txt
parentf4228163fb8f0f7e257aa6e824c2387cf0a6370e (diff)
Utilize NO_UNITY_BUILD arguments instead of manual exclusion
Unity build is disabled by default for all 3rdparty libraries, so we don't need to set the manually anymore; and for the plugins we can use NO_UNITY_BUILD instead. Pick-to: 6.5 Task-number: QTBUG-109394 Change-Id: Ia2f83ae083924d31adf07e7647b34ae6571ed01f Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/3rdparty/zlib/CMakeLists.txt')
-rw-r--r--src/3rdparty/zlib/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/3rdparty/zlib/CMakeLists.txt b/src/3rdparty/zlib/CMakeLists.txt
index 81fc649538..ee9ece80fc 100644
--- a/src/3rdparty/zlib/CMakeLists.txt
+++ b/src/3rdparty/zlib/CMakeLists.txt
@@ -34,8 +34,6 @@ qt_internal_add_3rdparty_library(BundledZLIB
$<TARGET_PROPERTY:Core,INCLUDE_DIRECTORIES>
)
-set_target_properties(BundledZLIB PROPERTIES UNITY_BUILD OFF)
-
qt_internal_add_sync_header_dependencies(BundledZLIB Core)
qt_disable_warnings(BundledZLIB)