summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-11-12 12:58:06 +0100
committerTor Arne Vestbø <tor.arne.vestbo@qt.io>2020-11-12 18:43:43 +0100
commit1777ddc234bb51dcf9b9c251e3872cc733a06e34 (patch)
treedbe82e9d64946c13fc0e8368509068b9e8c9a3f2 /src/CMakeLists.txt
parent4cc2196f6ae520d16c218a8599070050938f01f0 (diff)
cmake: Remove indirection via Startup target for EntryPoint
The EntryPoint interface target now contains all the logic for what flags and optional static libraries to add when the entrypoint is enabled. The target property QT_NO_ENTRYPOINT can be used to disable the entrypoint. Change-Id: I9b14ff729366cd6307789c969ebd4b2ca19de77d Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index aa4b1b06c4..bf71322b44 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -26,6 +26,8 @@ endfunction()
find_or_build_bootstrap_names()
+add_subdirectory(entrypoint)
+
add_subdirectory(corelib)
if (QT_FEATURE_concurrent)
add_subdirectory(concurrent)
@@ -70,6 +72,4 @@ if(QT_FEATURE_gui AND QT_FEATURE_widgets)
endif()
add_subdirectory(plugins)
-add_subdirectory(entrypoint)
-
add_subdirectory(android)