summaryrefslogtreecommitdiffstats
path: root/src/corelib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-09-11 11:01:13 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-09-11 19:36:26 +0000
commit1410cc24cce10f9711a98d5a2755ebdea750dd61 (patch)
treedc9afc1773ae856123dc8f4b1035ab58574fbc73 /src/corelib/CMakeLists.txt
parent08ed9ad137d903246f2aff5b29bb3478e3feeb5e (diff)
Regenerate src/corelib
Change-Id: Ibb69cad45169546fa97ee06881868cdbb082e9d6 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/corelib/CMakeLists.txt')
-rw-r--r--src/corelib/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/corelib/CMakeLists.txt b/src/corelib/CMakeLists.txt
index 47ba9ce7fc..b9aa03a496 100644
--- a/src/corelib/CMakeLists.txt
+++ b/src/corelib/CMakeLists.txt
@@ -239,6 +239,10 @@ add_qt_module(Core
INCLUDE_DIRECTORIES
${CMAKE_CURRENT_BINARY_DIR}/global # special case
# special case: remove ../3rdparty/...
+ PRECOMPILED_HEADER
+ global/qt_pch.h
+ NO_PCH_SOURCES
+ text/qstring_compat.cpp
LIBRARIES
ZLIB::ZLIB
# double-conversion # special case
@@ -250,11 +254,6 @@ add_qt_module(Core
PUBLIC_LIBRARIES # special case:
Qt::Platform # special case:
DISABLE_TOOLS_EXPORT # special case:
- PRECOMPILED_HEADER
- global/qt_pch.h
- NO_PCH_SOURCES
- text/qstring_compat.cpp
- tools/qvector_msvc.cpp
# special case begin
# Generated in QtBaseGlobalTargets
EXTRA_CMAKE_FILES ${QT_CORE_RESOURCE_GENERATED_FILE_PATH}
@@ -656,6 +655,8 @@ extend_target(Core CONDITION ICC
extend_target(Core CONDITION MSVC
SOURCES
tools/qvector_msvc.cpp
+ NO_PCH_SOURCES
+ "tools/qvector_msvc.cpp"
)
extend_target(Core CONDITION QT_FEATURE_commandlineparser